BindAPI: requisiti e limitazioni

Versione corrente (0.8 beta)

I requisiti di BindAPI sono estremamente leggeri, in quanto si riducono al solo compilatore Delphi.

BindAPI richiede in particolare Embarcadero Delphi 10.3 Rio. Non è escluso che possa funzionare con versioni precedenti di Delphi, ma non è ancora stato testato.

Attualmente BindAPI è in fase di test sotto Windows 10 con applicazioni a 32 e 64 bit. La versione attuale è da considerarsi una preview, abbastanza matura ma non ancora adatta ad applicazioni reali.

Versioni future

Obiettivi delle versioni future sono:

  • Supporto a Collections e array.
  • Compatibilità con FreePascal Compiler.
  • Verifica della compatibilità con Android 32 e 64 bit.
  • Verifica della compatibilità con tutta la serie di Delphi 10.x e seguenti.

Limitazioni

  • BindAPI non è ancora adatto ad applicazioni che richiedono risposte in real time.
  • BindAPI si basa sul presupposto che nessuna proprietà sia di tipo record.

Indice


Articoli più recenti:

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.